宮崎のWEB制作アドエス

WordPressを4.4にアップデートしたらエラーが出てしまった話

2015.12.19

とあるプラグインを試してみたくて、いくつかあるテストサイトの一つにログインしてみたところ、WPの更新情報が来てました。そのサイトはまだver.4.0シリーズだったので、4つのメジャーアップデートってことになるのかな。4.4へアップグレードしたのでした。

 

更新はダッシュボードから直接更新したのでですが、アップデート中に出ましたエラーが!

 

真っ白画面にエラーの文章が…

(※注:テストサイトなのでデバッグモードです)

 

 

内容は、”サイドバー1のidが設定されてないのでregister sidebar()が呼び出されました”みたいな文章だったと思います(詳細までは覚えてませんが)

 

念のためログアウト時のサイトを確認するとサイドバー(ウィジェット)がなくなっていました。

 

 

 

 

がーん

 

 

 

調べていくとWP4.2に更新する時にでてきたもので、ウィジェットの呼び出し方法がうまく設定できていない場合に出るエラーでした。

 

4.2より前のバージョンで作成され、functions.phpでウィジェットを有効化されている方は要注意ですよ。

 

ちなみに私はというと

register_sidebar();

これ1行だけでした… idどころか何も定義していない(汗)

 

 

参考にさせていただいたサイト

【アップデート情報】WordPress4.2のデバッグモードでエラーメッセージが出た時の対処法